Importing from table leaves project in a bad state

Hi, first of all - thank you for making Capitally - it looks like exactly the solution I’ve been searching for!

I’m just having a problem with trying to import some of my own data though. When I use the custom “Transactions in a table” import option to load a CSV, the importer gives me the all-clear (no errors and the “Import Summary/Changes to be applied” window looks right).

But after that, my project ends up in a bad state:

On futher investigation, the problem appears to be that the dates in my CSV didn’t get parsed correctly (the importer didn’t highlight this at the time):

I can try another import with manually entered dates next, but I’m left with a couple of problems:

  1. How can I get my project back into a good state? I can’t see how to delete these bad transactions as don’t show up in the transactions tab.
  2. How can I delete a project? I’ve ended up creating multiple projects while working around this issue.

Hello @Alastair, I’m glad you like it :slight_smile:

Improvements to imports are queued just right after the dividends, and one of the issues I want to address there is parsing the dates. Do you have the dates in the DD/MM/YYYY format by any chance? Or something different?

I’ll also check the error reports, as it generally should not happen, so many thanks for reporting.

Regardless, you can always Undo any operation in the project:

And you can delete projects by going to Settings → General → Delete Project

Oh, I won’t find any error reports because you have disabled the analytics - but that’s fine.

I have a one small request - could you send me a couple of dates that you think have broken the import? That would help me ensuring they will work in the future (or at least give you a warning).

Ah thank you for the pointers - I’ve managed to clean most of my mistakes up now! There’s just one old project that I haven’t been able to delete as I don’t have the password any more. I can definitely live with that though.

You’re right about my date format too. Here’s an example of the original data from my CSV: “19/06/2024”.

1 Like