Issue importing transactions

Having a challenge with importing transactions from Excel.

In Excel, I have a date like 12/17/2020, but it imports like 12/16/2020 11:59 PM, so the previous day.

Any idea what could be causing this?

Does it look like this on the import screen and only after the import the transaction is one minute back, or you see 11:59 immediately?

CleanShot 2024-07-09 at 20.04.49@2x

No, it looks that on the import screen itself. See screenshot.


Oh, the gray value above the input is what you have in the Excel file. You will need to correct it there or use a Formula in the import template.

If you see it differently in Excel, it might be due to date formatting, or discrepancies caused by the Excel importer. You might also try exporting to CSV from Excel to see if the date is correct then.

I tried a variety of date formatting options in Excel. None of them resolved the issue. In Excel, I just see the date. As you suggested, saved as CSV. That solved the problem. Thank you.

It doesn’t matter how you format the date in Excel, as the XLS file will have the underlying number always the same. Exporting to CSV exports the values as you see them - that’s why it works.

If you plan to export from this excel more frequently, you can also just copy the data and paste it in Capitally - which should act the same as a CSV export, just with fewer clicks