Price updates issue

Hi. Checking my positions (BCI•CLP321331116•Chilean Stock Exchange), I can see an issue with the last price update (1 day ago):


Thinking about this, I’d like to ask if would be possible add the last update in the header price (more useful and quick):

Thank you.

Update: I don’t know why, but it’s updated now :grimacing:

It might be a glitch on our data-provider side. Also, the end-of-day prices may be sometimes delayed even by a couple hours for certain exchanges as they’re being indexed.

I think it’d be reasonable to add last update date to the third row

1 Like

Yeah, date + time, similar to the current column I guess. Thank you Rafal.

It’s happening again. I’d appreciate if you can look further about this issue. Thanks.


I just pushed a new release that adds the last updated date to Price tab.

Your issue may stem from the time zones. If it repeats once again, please open the Asset → Price tab and hover on the Last Price Update value with your mouse. A tooltip will show up with the UTC date of the last price update - please paste it here.

1 Like

Yes, it’s happened again. The time here now is 17:28 but look what I see:

In addition: when I opened the website few minutes ago, I checked the last price updated in the column and was good, just few minutes ago (17:15 or something like). I noted the website was not update to the latest version because I didn’t see the last price update in the header. Then the site was updated to the latest version and I got this big delay again (the image I shared). Finally, I can say that I always see sandwich menú above with a circle/loading. I guess means an updating.

Thank you Rafal.

When you checked this, what was your local time - 13 or 17?

As I mentioned at the beginning, local time was 17:28. Thanks.

Then there’s a bug somewhere with how time zones are applied. The tooltip should show the time in UTC as it ends with “Z” but shows your local time. That’s why the text says 13, as it applies your local time zone to the wrong time. That’s also why you’ve seen “yesterday” before.

I’ll look into that.

1 Like

@rafal I’m using the app in the last hour and the last price update disappeared from the header:

Also in positions:

Thank you.

@claudioivm Ok, I’ve read through the logs and I think I understand what’s going on now.

For many markets, the closing prices are not available immediately after exchange close. In some cases, it may be delayed by even 4-5 hours.
In such case, Capitally uses the latest intraday price it has, and in your case the last time the intraday price was checked was 17:58UTC - which is 13:58 in your time zone.

In most cases, the last intraday price available still can be fetched from the provider some time after the exchange close. I’ve extended this time window to be 5 hours, so next time you should see the price that is more up-to-date. I’ll be pushing this update within the next 1-2 hours.

I don’t know why the information disappeared for you - it might not show up if prices are not yet fetched, but in your case they definitely are :confused:

Anyways, Capitally is currently optimized for long-term tracking, where you mostly operate on end-of-day prices and longer time spans. But of course if the data is available, it will source the latest one it can get.

I see. The last price update is back but with a delay. What’s the price update frequency currently? 1 hour? Here it’s 12:46 now. Thank you Rafal.


Btw, these are the trading hours in the chilean stock market: The Santiago Stock Exchange is open Monday through Friday from 9:30 am to 4:00 pm Chile Standard Time (GMT-04:00). So, the stock market is opened up to 20:00 UTC. I guess with your new extension will be enough to get the last prices, right? Thanks again.

The 5 hours I’ve mentioned are after the exchange closing time, which is exactly as you pointed within the system. So at least in theory, after 20:00 UTC if there won’t be any official end of day price, the system will query the current intraday price, which should be very close if not the same as the closing price. I won’t guarantee it will work for Santiago Stock Exchange, but we’ll know today :sweat_smile:

There are a couple timeouts in play:

  • data-provider gives us 15-min delayed intraday prices
  • server checks them not more often than every 30 minutes
  • client updates the price not more often than every 15 minutes

So the delay can range from 15-60 minutes if you’re really unlucky. Most of the time will be somewhere in-between.

1 Like

Finally is working fine I think, great! Btw, in mobile, I think you could put all the info in one line. Thanks Rafal.

1 Like

Yep, it should definitely be in one line…

1 Like

For some reason, the last price update disappeared from desktop version. So, trying to figure out what’s going on, I removed all the site data in Chrome. I relogged and voilá, all solved. Now I’m thinking if is related to a Chrome extension I use (uBlock Origin), because I can see several blocked requests, over and over:

Thank you Rafal.

Sentry does error and performance monitoring - it won’t affect the app functionality. I just won’t see any error or performance logs from your device.

I’ll double-check the logs and will try to replicate it somehow, as it’s strange it disappears. Unless there was a problem with cached data you just solved by clearing the cache.

Edit: I’ve found one place that could be a culprit. It doesn’t affect the price, just reporting of the last update date.

Out of curiosity - can you tell me what’s your use case so I understand it better? Why you need the prices to be always up to date? (Nothing wrong with that of course :sweat_smile:)

1 Like

No worries. Because I’m an active trader too (swing) so, in some investments I’d like to use Capitally instead the brokers. At the end is about my main goal I think; track all my money/investments in one place. Cheers Rafa.

1 Like